Chi segue Saurik su Twitter avrà avuto modo di leggere un “piccolo litigio” con il RipDev riguardo un package compilato da Saurik che viene pre-installato con Cydia. Si tratta della Libreria libgcc che viene utilizzata praticamente per tutte le applicazioni e che secondo il RipDev era corrotta, essendo stata importata direttamente dai vecchi firmware 1.x, senza alcuna modifica.

img_00821 img_00831 img_00841

Il tutto parte dal firmware 3.0 e dalla domanda che il Ripdev ha rivolto a Saurik cercando di capire se avesse intenzione di portare una libreria corrotta anche sul 3.0. Saurik ha chiesto maggiori dettagli sull’errore e da qualche ora è disponibile in Cydia un “Aggiornamento Essenziale” che riguarda proprio questo package. Non si notano miglioramenti di alcun tipo ed in nessuna circostanza, però sicuramente vi invito ad aggiornarlo.

Tutto quello che dovete fare è aprire Cydia ed un pop-up vi notificherà la disopnibilità dell’aggiornamento.

Grazie anche ad eema per la segnalazione